problemes d apparance et de liens sur mon site

Voir le sujet précédent Voir le sujet suivant Aller en bas

problemes d apparance et de liens sur mon site

Message par zalouh le 1/5/2010, 20:47

bonjour,
tout d abbotrd je tiens a remmercier tous les gens qui resolvent les problemes dans ce forum car ils m ont ete d une aide immense!
j ai fait mon site avec iweb 09 et il est heberge chez 000webhost.je passe sur tous les problemes que j ai eu a le publier.....
mais maintenant,il se trouve qu il y encore quelques details qui coincent....
-sur certains ordinateurs le "fonts" de mes textes est different et du coup tres laid et pas au bon endroit
-depuis la page "contacts" et la page "services",il est impossible d aller sur un autre page.il faut utiliser la fleche du navigateur web (firefox,safari...) pour retourner a la page precedente pour pouvoir enfin en visiter une autre.
-certains de mes liens sont errones.en cliquants sur "short-movies" depuis la page "documentarie" et "and more" on se retrouve sur "services" ou "and more".....
-la disposition du texte sur la page "contacts est differente que dans iweb....
-et pour finir le background de la page "promotionnal clips" a un gros carre gris.mais ceci dit pas depuis tous les ordis...
alors la question est:
c est quoi le probleme?
pourquoi le site n est pas tel quel je le vois depuis mon ordi sur iweb?
mon site :www.za-p.com
merci

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par el padre le 1/5/2010, 21:27

bonjour,

d'après ce que je sais, tous les navigateurs n'interprètent pas les fonts de la même façon. Pour te rendre compte du rendu de ton site tu peux le tester en ligne ici. En ce qui concerne les déplacements de texte etc, j'ai pu remarquer que tu devais utiliser un enchevêtrement de plusieurs rectangle de texte. Là encore, un navigateur A peut l'interpréter différemment qu'un navigateur B. Je te conseille plutôt de ne pas les croiser, quitte à appliquer différentes modifs de texte.

Pour les liens, si tu as fait des copier/coller, des fois ça ne marche pas. Pourquoi? Je ne sais pas. Il m'est arrivé plusieurs fois la même chose, depuis je refais sur chaque page un lien.

Pour le carré gris enfin là je sèche, n'ayant rien remarqué.

Voilà pour moi, en espérant t'avoir aidé, bon week end good

-------------------


mon blog: http://web.me.com/blaisecorneloup/equity/

el padre
iWeb - Modo

Messages : 345
Inscription : 11/04/2008 Age : 35
Localisation : sur mes pieds ou presque
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par zalouh le 1/5/2010, 21:49

merci de t interesser a mon cas.
pour les fonts,en fouillant un peu mieux sur le forum.il suffirait apparemment de transformer les textes en images.Ce que je vais faire.
si tu ne vois pas le carre gris,tant mieux!il n apparait que sur mon ordinateur......mais bon...
pour les liens,il s agit en fait de texte comme "documentaries" qui sont utiliser en tant que bouton.ils se dirigent a des sous-pages (qui se trouvent dans mon propre site) qui n apparissent pas dans le menu.donc je n ai pas fait de copier/coller.....
a+ tourner la tete

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par koeklin le 1/5/2010, 23:03

Une page iWeb a quatre 4 zones
- une zone de navigation (menu)
- une zone d'entête (video Maker etc. et ZA-P)
- une zone de contenu principal
- une zone pied de page

Sur les pages Services et Contacts, la zone de navigation est sous une partie de la zone de contenu, je pense que la faute est due à la présence et mal-positionnement de cette image "dirty grunge" marron servant de fond sur ces deux pages.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par zalouh le 1/5/2010, 23:34

En effet!
merci!!!
c est sans doute l erreur la plus stupide que j ai faite jusqu a maintenant!et j en ai faites.....confus
du coup ce probleme la est resolu!!!
apparemment celui des "fonts" aussi mais il faut que je verifie depuis un autre ordinateur....
pour les liens...c etait aussi une erreur stupide....je n avais pas selectionne les lettres des textes mais juste cliquer dessus.... confus en faisant les hyperlinks...du coup maintenant ca marche aussi.
par contre la page "filmography" et la page "promotionnal clips" sont completemet surprise
et je ne vois pas pourquoi tout est sans dessus dessous comme ca....

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par koeklin le 2/5/2010, 10:18

C'est quand même bizarre les images sont pourtant répertoriées dans le dossier Filmography_files,
mais elles ne s'affichent pas.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par zalouh le 2/5/2010, 20:23

bonjour,
apparemment le probleme s est regle tout seul....quand je vais sur le site (www.za-p.com),tout est ok.Et depuis chez vous?

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par koeklin le 2/5/2010, 23:49

Tout semble ok depuis chez moi.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par zalouh le 3/5/2010, 12:34

ok!merci encore pour tout!
tout ca m a fait gagner du temps!!!
il y a encore un fond noir (une forme),en transparance sur quelques textes depuis windows explorer qui empeche d acceder aux autres pages...mais j imagine qu en les ajustant et en faisant "send to back",tout ira bien.je dois dire que pour moi c est pas vraiment encore au point cette fonction de "send to front","send to back" etc....
encore une petit question de simple curiosite.....en visitant quelques sites depuis ce forum,j ai vu que c etait possible de mettre une image de fond sur toute la surface de la page et non uniquement au centre....comment? respect

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par koeklin le 3/5/2010, 14:31

zalouh a écrit:encore une petit question de simple curiosite.....en visitant quelques sites depuis ce forum,j ai vu que c etait possible de mettre une image de fond sur toute la surface de la page et non uniquement au centre....comment? respect
On utilise l'inspecteur pour mettre une image en arrière-plan :
inspecteur > inspecteur de pages > disposition
Quoi qu'il en soit l'image disposée en arrière-plan sera toujours centrée verticalement et horizontalement donc j'ai besoin d'un exemple pour comprendre le sens de votre question.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par Yanik le 3/5/2010, 18:06

Bonjour,

Zalouh évoque sans doute l'arrière plan de la page et l'arrière plan du navigateur. Les deux peuvent bénéficier d'un remplissage image. Pour avoir une image sur toute la page comme le dit Zalouh, il faut en fait mettre cette image dans l'arrière plan du navigateur ("remplissage image") et faire le choix " aucun" dans arrière plan de la page.

Pour ceux qui découvrent iWeb rappelons :

1 - Que les interventions sur l'arrière plan du navigateur se limitent à la couleur ou à l'insertion d'une image. On ne peut rien y déposer par dessus (texte, photos, vidéos etc.). Essayez voir pour comprendre (en déplaçant un objet sur les bords)..

2 - La page est sur l'arrière plan du navigateur (au-dessus pour dire autrement).

3 - Que l'arrière plan de la page peut se colorer ou recevoir une image. Vous pouvez modifier ses dimensions. Et vous pouvez intervenir dessus : déposer textes images, etc...
La commande "disposition" agit sur les objets et textes déposés sur la page, en particulier avancer ou reculer d'un plan, mettre en premier ou en dernier plan.

Si vous voulez une vision concrète :
- Imaginez une table : c'est l'arrière-plan du navigateur. Vous pouvez uniquement la peindre de la couleur de votre choix ou y coller une photo géante qui couvrira toute sa surface. Vous n'avez pas le droit d'y mettre quoique soit d'autre.
- Sur cette table, il y a une feuille (c'est la page) dont vous pouvez choisir les dimensions et le décors (couleur, image, voire la rendre invisible).
- vous pouvez y déposer des petites feuilles invisibles qui contiendront des textes, des images, etc, eux bien visibles. Ces petites feuilles (on parle aussi d'objets), vous pouvez les déposer cote à cote mais elles peuvent aussi se chevaucher dans l'ordre que vous souhaitez grâce à la commande disposition. Vous pouvez aussi les colorer, mais si elles contiennent du texte, elles resteront transparentes.
- et comme le Web, c'est bizarre parfois, il faut bien vérifier que l'objet que vous voulez en premier plan est bien en premier plan. Car il arrive que ce qu'on voit à l'écran d'iWeb peut être différent de ce qu'on voit sur le site.

Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par zalouh le 3/5/2010, 23:07

Bonjour,
merci.c etait ca ma question.
desolee de ne pas avoir ete tres claire...comme l a dit Yannick,je faisais reference a l'arrière plan de la page et l'arrière plan du navigateur.
merci encore a tous pour votre aide!!!!!!
je ferais surement de nouveau appel a vous....mais j espere que ce ne sera pour tout de suite....
Bonne fin de soiree! good
ps.:sympa la "vision concrete".

zalouh
Simple Membre

Messages : 11
Inscription : 01/05/2010 Localisation : www.za-p.com
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problemes d apparance et de liens sur mon site

Message par Contenu sponsorisé Aujourd'hui à 08:43


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum