problème de disposition d'images

Voir le sujet précédent Voir le sujet suivant Aller en bas

problème de disposition d'images

Message par eskapoint le 28/9/2010, 18:10

Bonjour à tous,

Je suis actuellement entrain de créer le site de mon entreprise avec iweb. J'ai créé une bannière avec bannerzest et celle ci est recouverte en partie par un fond semi-transparent sur lequel est affiché du texte.
C'est cette superposition de plusieurs éléments qui à mon avis crée le trouble sur ma page. Enfin ce n'est pas aussi simple, car sur l'un ça fonctionne et pas sur les autres...
Je n'arrive pas a trouver une solution rationnelle à ce problème.
L'ordre d'affichage est pourtant bien réglé dans iweb, mais c'est toujours la bannière qui passe devant.

Et pour illustrer mon propos :
la page où ça marche : ici
la page où ça marche pas : là

Je m'en remet donc à votre expertise chers iWeb-forumeurs


sk.

eskapoint
Nouveau

Messages : 1
Inscription : 28/09/2010 Localisation : 70
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de disposition d'images

Message par Madeline le 28/9/2010, 18:31

pour moi les deux ne marchent pas pale

-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html

Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: problème de disposition d'images

Message par Yanik le 28/9/2010, 20:35

Bonsoir,

A tout hasard : avez vous essayé la commande "disposition" ?

Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: problème de disposition d'images

Message par koeklin le 28/9/2010, 22:13

Voici deux pages qui contrairement à ce que l'on voit et ce que l'on pourrait supposer n'ont pas la même disposition!
Une page iWeb a 4 parties, 4 parties que l'on retrouve dans les codes des pages publiées,
4 parties qui sont chacune sur un plan différent.

Ces 4 parties sont
la partie navigation (html : nav_layer) ------> z-index 0
l'entête (html : header_layer) -----------------> z-index 10
le contenu (html : body Layer_layer) --------> z-index 5
le pied de page (html : footer_layer) --------> z-index 15
Plus le z-index est important plus le plan sur lequel il est situé est superficiel. (ici ce sont les valeurs du thème blanc et noir)



Ici dans votre première page citée, tous les éléments sont placés dans la partie navigation (sauf le menu et la phrase au bas de la page qui sont situés dans le contenu)
dans la seconde page tous les éléments sont placés dans le contenu sauf le fond gris qui placé dans la partie navigation (situé dans un calque bien plus profond).

il faut afficher la disposition quand on bosse sur une page et quand on bouge une objet il faut faire attention à la position de votre curseur sur cet objet, si le curseur franchit une ligne de séparation entre 2 parties alors l'objet se placera dans la zone où le curseur se trouve.
généralement quand un objet change de zone il apparait un grand rectangle bleu clair autours de la partie où va être placé l'objet.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de disposition d'images

Message par DrOSX le 30/9/2010, 09:45

Je ré-édit le titre et déplace le sujet dans le forum "images".

-------------------
Pas de support par M.P - Si vous avez des soucis de connexion, un POST est crée pour vous

DrOSX
Administrateur

Messages : 1338
Inscription : 15/10/2007 Masculin Localisation : Atlantique/Altitude 0
Version iWeb : 3
Publication : locale

Revenir en haut Aller en bas

Re: problème de disposition d'images

Message par Contenu sponsorisé Aujourd'hui à 16:25


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum