bug de publication d'un site sur un serveur FTP

Voir le sujet précédent Voir le sujet suivant Aller en bas

bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 6/2/2011, 21:08

Bonjour à tous,
en tant qu'animateur du site international des Modules Juniors, UAICF (Union Artistique et Intellectuelle des Cheminot Français, filiale SNCF) j'ai du faire un site en septembre 2010 afin d'enregistrer des plan de modules réalisé sous word ou anyrail au 1/10 puis à télécharger, cela permettait aux organisateur de manifestation ferroviaire de faire des PLAN au 1/10 de leurs salle et des modules (maquette de train) présents.

Le site est depuis cette date en ligne ( http://lemodulejunior.uaicf.asso.fr ) je l'ai réalisé entièrement avec IZISPOT, mais depuis que j'ai acheté mon IMAC 27" j'ai eu la surprise de découvrir IWEB,
et j'au aussi découvert que l'on pouvait faire un site beaucoup beaucoup moins vieillot !

notre démarche ' le module junior ' à depuis septembre évolué, je suis tenu de modifier le site pour l'internationaliser, c'était l'occasion pour le refaire avec IWEB.

Les premières pages ont été crées, j'ai téléchargé FILLEzilla pour supprimer les documents présents dans mon répertoire httpdocs sur le serveur, puis j'ai lancé la publication du nouveau site,

malheur à chaque fois, IWEB prépare mon site à la publication, puis publie quelques pages et s'arrête subitement me disant qu'une erreur inconnue est survenue, que faire ????

j'ai supprimé le répertoire crée avec fillezila et j'ai rechargé le site avec IZISPOT comme vous pouvez le voir sur le lien ci-dessus ...

Si quelqu'un peut m'aider quand à ce bug cela me serait fort utile.

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 6/2/2011, 23:44

Bonjour

Une remarque en passant:
Passer d'un logiciel de création de site dynamique à un logiciel de création de site statique ne me semble pas une bonne idée.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 6/2/2011, 23:45

Que dois-je alors faire ? demander à mon hébergeur de vider totalement le serveur pour ensuite basculer grâce à un site statique, cela corrigera mes problèmes ?

Merci de votre réponse.

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 7/2/2011, 00:48

Ma remarque n'avait aucun rapport avec votre bug. C'était juste sur le choix du logiciel pour "internationaliser" votre site. iWeb est un logiciel assez fermé, limité, produisant des pages lourdes, uniquement en HTML, présentant souvent des problèmes de compatibilité avec certaines versions dues à une utilisation abusive de javascript.

Quant à votre problème, vous pouvez, dans un premier temps, publier iWeb dans un dossier et téléverser (upload) le contenu de ce dossier dans le dossier racine de votre serveur grâce à FileZilla comme vous le faisiez avec votre précédent site. On verra la publication directe d'iWeb vers votre serveur plus tard.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 7/2/2011, 00:55

Je n'ai jamais utilisé FileZilla pour transférer les données, Izispot le fait tout seul comme Iweb en rentrant identifiant, mot de passe, adresse du serveur, port et chemin distant.

Dans mon serveur j'ai :

cgi-bin
conf
error_docs
httpdocs
httpsdocs

Si j'utilise FileZilla, dois-je supprimer ces dossiers ?
dois-je envoyer tout les fichiers dans le répertoire httpdocs comme le fait Izispot ?

Merci d'avance pour toute l'aide que vous saurez m'apporter.
diesel52

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 7/2/2011, 18:05

Non, vous ne supprimez pas ces fichiers

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 7/2/2011, 21:51

OK pour ne pas supprimer les dossiers,
mais, Si je souhaite envoyer les fichiers, quel dossier dois-je envoyé sur le répertoire ?
En effet, ça enregistre (dans le disque local) un dossier au nom du site avec tout les fichiers du site.

Est-ce que je dois juste mettre le dossier au nom du site dans httpdocs ou est-ce que je dois placer la totalité des fichiers moi même un par un ( surprise )

Merci d'avance.
Johann.

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 8/2/2011, 11:48

Quand vous publiez dans un dossier de votre Finder, vous avez
  • un dossier Nom_de_site (nom que vous avez choisi, qui s'affiche dans la colonne latérale d'iWeb et dans les réglages de publication),
  • une page index.html et
  • un fichier .plist

vous devez mettre ces trois éléments dans le dossier racine de votre serveur.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 8/2/2011, 20:32

Ok, merci bien Wink
donc si j'ai bien compris,

dans mon dossier httpdocs, je dois mettre :

mon dossier Nom_de_site
La page index.html extraite du dossier Nom_de_site
et le fichier .plist que je ne trouve pas salut

Merci encore pour prendre le temps de vous occuper de mon " cas " !

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 9/2/2011, 00:09

Si je vous suis bien, vous regardez dans le mauvais dossier.
Vous fouillez le dossier Nom_de_votre_Site où se trouve également une page index.html (qu'il faut laisser à sa place) alors que vous devriez fouillez son dossier "Parent " (dossier qui contient le dossier nom_de_site

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 9/2/2011, 01:00

Oui excusez moi de ma maladresse.
J'ai tout effacé du serveur (en faisant une sauvegarde de sécurité avant
et j'ai envoyé les fichiers comme vous me l'avez indiqué ... Mais, non en fait il n'y a pas de mais, c'est super cela fonctionne à merveille !

une énorme différence avec l'ancien : http://lemodulejunior.uaicf.asso.fr

Maintenant nous pouvons travailler sur le sujet " comment régler l'envoi automatique "
et une autre question ... J'ai vu en début d'année avant de créer ce site que sur certaines page il y avait " créer avec un mac " plus la pomme, comment retrouver cette icône ? j'aimerais la glisser dans la partie Contact du site pour faire un petit coup de pub pour les Macintosh ...

Merci encore

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Madeline le 9/2/2011, 01:33

koeklin a écrit:Quand vous publiez dans un dossier de votre Finder, vous avez
  • un dossier Nom_de_site (nom que vous avez choisi, qui s'affiche dans la colonne latérale d'iWeb et dans les réglages de publication),
  • une page index.html et
  • un fichier .plist

vous devez mettre ces trois éléments dans le dossier racine de votre serveur.

moi je ne mets pas le fichier .plist pale
est-ce grave docteur Koeklin ?

-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html

Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 10/2/2011, 00:58

Bonjour, j'ai trouvé pour le bouton crée avec un mac.
Cepandant j'aimerais savoir :
j'ai essayé de remettre à jour le site automatiquement avec l'option publié sur un serveur FTP, mais quand je met le dossier parent ou est situé le dossier Nom_de_site avec la page .plist et l'index. Il me disent que le dossier existé déjà, et si je veut le remplacer ou non ?
Normalement cela ne doit pas poser problèmes car effectivement le dossier existe déjà mais je fais une mise à jour ? cela doit être automatique non ?
Donc pour le moment je n'ai rien fait car je ne veut pas faire buGer le site et tout refaire à 0 avec Filezilla ...

Merci pour toute l'aide que vous saurez m'apporter.

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par koeklin le 10/2/2011, 20:01

Madeline a écrit:moi je ne mets pas le fichier .plist pale
est-ce grave docteur Koeklin ?
Tellement grave que j'en ai pas aussi trés happy
Par contre tu continues à publier dans un dossier?

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Diesel52 le 10/2/2011, 20:06

koeklin a écrit:
Par contre tu continues à publier dans un dossier?

Madeline ou moi ?

Diesel52
Simple Membre

Messages : 13
Inscription : 06/02/2011 Localisation : haute marne
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Madeline le 10/2/2011, 20:22

koeklin a écrit:
Madeline a écrit:moi je ne mets pas le fichier .plist pale
est-ce grave docteur Koeklin ?
Tellement grave que j'en ai pas aussi trés happy
Par contre tu continues à publier dans un dossier?

oui je publie dans un dossier et je mets en ligne via Cyberduck...
car j'ai à ce jour 6 sites, 2 domaines et 4 sous-domaines des deux domaines, tous hébergés chez Hostpapa pour le prix d'un seul hébergement !!!
donc je préfère faire comme cela, je contrôle mieux ce que je mets en ligne !!!
et le tout va très bien...
bon donc je continue à virer le fichier plist... qui sert à quoi... docteur Koeklin ???


-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html

Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: bug de publication d'un site sur un serveur FTP

Message par Contenu sponsorisé Aujourd'hui à 10:41


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum