liens absents de certaines pages!

Voir le sujet précédent Voir le sujet suivant Aller en bas

liens absents de certaines pages!

Message par photomarcus le 21/10/2011, 19:35

Bonjour,

J'ai crée un menu au dessus de mes pages à l'aide d'images crées ds PS (je sais ce n'est pas conseillé pour le référencement)...
J'ai 6 pages au total. Sur deux d'entre elles(blog et liens), les liens ne fonctionne pas sous safari ni chrome
alors que ce sont les meme boutons sur toutes les pages. J'ai créé un menu avec mes 6 boutons et j'ai fait un copier coller sur toutes les autres pages.
Sous IE ça fonctionne! Sur Chrome idem que sur safari!
www.marcguillaumeportfolio.be

C'est en construction donc pas d'affolement... non

Merci

photomarcus
Simple Membre

Messages : 30
Inscription : 04/10/2011 Masculin Localisation : Bruxelles
Version iWeb : 3
Publication : Ftp integré

http://www.marcguillaumeportfolio.be

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par koeklin le 22/10/2011, 13:24

Bonjour

Une page iWeb a 4 parties
chacune de ces parties est sur un plan différents
de haut en bas on trouve
la navigation
l'entête
le contenu
le pied de page

mais d'arrière en avant on trouve
la navigation (nav_layer)
le contenu (body_layer)
l'entête (header_layer)
le pied de page (footer_layer)



Quelques renseignements ici

Chaque partie peut déborder sur une partie voisine c'est le cas de votre menu est dans le contenu de la page mais qui déborde dans l'entête et est recouvert par cette dernière.
Quand vous copiez un élément dans le contenu de la page et que vous le collez sur une autre page il se colle probablement sur le même calque. le problème c'est que le l'entête est plus haute sur le blog du fait e la position du titre "blog" qui est dans l'entête. Si un lien est recouvert il ne fonctionne plus.
Affichez la disposition et mettez votre menu dans l'entête et non dans le contenu de page.


-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par photomarcus le 22/10/2011, 19:52

Merci Koelin, une fois de plus tu m'aides à comprendre... tourner la tete
De là à dire que les problèmes sont résolus!

Alors, ce que j'ai remarqué par rapport à tes explications:

je n'avais sur aucune page d'entête. La valeur de la hauteur était à zero!
Mon calque naviguation se trouvait de ci de là, une fois en haut une fois au milieu de la page...
A mon avis c'est là le problème (que je ne vois pas comment résoudre)

Donc j'ai augmenté la valeur du calque entête et j'y ai mis les deux pavés avec mon nom, la photos des yeux ainsi que mon menu.
Surprise, en publiant en local, plus aucun lien de mon menu ne fonctionne...

Après vérification, j'ai remarqué que mon calque navigation s'était mis en dessous (plus bas) que mon entête. Je ne parviens pas à remonter celui-ci sauf si je diminue la valeur de la hauteur de mon entete. Si mon calque entête est à zero, alors mon calque navigation est en haut de page. Dans ton exemple, l'entete est en dessous de la navigation!

photomarcus
Simple Membre

Messages : 30
Inscription : 04/10/2011 Masculin Localisation : Bruxelles
Version iWeb : 3
Publication : Ftp integré

http://www.marcguillaumeportfolio.be

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par photomarcus le 23/10/2011, 11:04

Je viens de revérifier...sur toutes mes pages, l'entête se trouve bien au dessus du calque navigation!si je diminue la hauteur de l'entête, le menu navigation suit en montant aussi (puisqu'il est accolé)
si je crée une nouvelle page, la navigation est bien au dessus!
Je crains le pire. J'espère ne pas devoir tout refaire?

photomarcus
Simple Membre

Messages : 30
Inscription : 04/10/2011 Masculin Localisation : Bruxelles
Version iWeb : 3
Publication : Ftp integré

http://www.marcguillaumeportfolio.be

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par koeklin le 23/10/2011, 20:23

Vous n'avez rien dans votre calque de navigation "nav_layer" (qui ne concerne quelle menu par défaut proposé par iWeb, quand on l'affiche) . Votre menu est un menu personnalisé fait de simple liens : vos liens sur le calque de contenu "body_layer"

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par photomarcus le 23/10/2011, 21:32

J'ai passé l'après-midi à refaire toutes mes pages afin d'avoir la structure souhaitée cad nav layer(que je n'affiche pas à la publication) puis entête puis body puis pied de page. Dans mon entête, j'ai placé mes pavés, ma photo des yeux et mon menu. Le reste dans body.
Lorsque je publie, les liens de mon menu ne fonctionne que sous IE. ni sous Chrome, ni sous safari (mac ou pc) ni sous firefox
Je ne comprend plus rien...
Il y a une logique qui pour l'instant m'échappe et ça...m'énerve (de ne pas comprendre).

photomarcus
Simple Membre

Messages : 30
Inscription : 04/10/2011 Masculin Localisation : Bruxelles
Version iWeb : 3
Publication : Ftp integré

http://www.marcguillaumeportfolio.be

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par photomarcus le 23/10/2011, 23:37

Voilà, j'ai trouvé! Les liens qui étaient dans l'entête ne fonctionnaient pas sous safari chrome et firefox. Je les ai mis dans le contenu et là ça fonctionne. Pourquoi, ça pas la moindre idée mais ça marche...

Merci mille fois.

photomarcus
Simple Membre

Messages : 30
Inscription : 04/10/2011 Masculin Localisation : Bruxelles
Version iWeb : 3
Publication : Ftp integré

http://www.marcguillaumeportfolio.be

Revenir en haut Aller en bas

Re: liens absents de certaines pages!

Message par Contenu sponsorisé Aujourd'hui à 10:42


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum