Vidéo et Firefox

Voir le sujet précédent Voir le sujet suivant Aller en bas

Vidéo et Firefox

Message par allégorie le 19/3/2012, 13:19

Bonjour à tous le monde,

J'ai fait une grosse mise à jour de mon site (changements graphiques et ajouts de vidéos)
Le soucis est que les nouvelles vidéos que j'ai misent ne passent pas avec firefox alors que j'ai utilisé le même protocole pour les ajouter alors que les anciennes vidéos fonctionnent correctement à l'exception d'une seule. Les vidéos sont en HTML 5 et tout est ok avec IE et safari.
L'autre soucis est l'apparition d'un cadre et une ombre bizarre sur les titres de pages.
Les titres sont fait à partir de Iweb sur un élément graphique fait avec photoshop en PNG.
Je publie sur mobileme avec Iweb 3.0 et OS 10.5.8. Je n'ai eu aucun soucis au moment de la publication.

Si quelqu'un à une idée...

Le lien du site :
http://www.allegorieproductions.com

Merci d'avance.
Cordialement.


allégorie
Simple Membre

Messages : 26
Inscription : 09/03/2011 Masculin Localisation : Eure et loir
Version iWeb : A remplir!
Publication : MobileMe

http://www.allegorieproductions.com

Revenir en haut Aller en bas

Re: Vidéo et Firefox

Message par koeklin le 20/3/2012, 23:55

Avez-vous éditer le fichier .htaccess de votre serveur ?
Code:
AddType video/ogg .ogv
AddType audio/ogg .oga
AddType video/mp4 .m4v .mp4

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Vidéo et Firefox

Message par allégorie le 21/3/2012, 12:23

Bonjour,

Non je n'ai rien éditer du tout et d'ailleurs je ne trouve pas ce fichier sur mon serveur (Idisk).
Quand j'ai chargé les nouvelles vidéos, je les ai simplement fait glisser d'un dossier de mon mac dans le dossier vidéo sur ma partition Idisk. J'aurais peut-être du utiliser Cyberduck???
Pour l'édition des vidéos sur le site, j'ai utilisé un widget vidéo vierge dans lequel j'ai copié collé le code d'une vidéo qui fonctionnait puis j'ai remplacé les adresses qui correspondaient à l'emplacement des vidéos sur le serveur grâce à Cyberduck.
En tout cas merci pour ton aide.

Cordialement
Bruno

allégorie
Simple Membre

Messages : 26
Inscription : 09/03/2011 Masculin Localisation : Eure et loir
Version iWeb : A remplir!
Publication : MobileMe

http://www.allegorieproductions.com

Revenir en haut Aller en bas

Re: Vidéo et Firefox

Message par koeklin le 21/3/2012, 13:47

Vos vidéos sont en quels formats? Webm, mp4, ogv?
firefox lit les webm et les ogv
Chrome lit les webm
IE et Safari lisent les mp4 h264
Perso j'encode les vidéos en mp4 h.264 (pour IE et Safari) et en webm (pour Chrome et Firefox)
Mais pour firefox, un fichier webm ne suffit paas il faut aussi renseigner le fichier .htaccess du serveur

Bon le code ci-dessus est éronné il date des début du HTML5, de la période où firefox ne lisait que du ogg (ogv et oga) et non du webm. Perso, j'utilise celui-là
Code:
AddType video/ogg  .ogv
AddType video/mp4  .mp4
AddType video/mp4  .m4v
AddType video/webm .webm
[code]la ligne ogv est inutile vu que j'utilise pas ce format et je pourrais combiner la ligne mp4 et m4v comme cela est fait dans le code précédent mais ce qui est important c'est la ligne webm qui n'était pas présent dans le code précédent.
J'utilise plus MobileMe depuis de nombreuses années, je ne sais pas si on peut lui ajouter un fichier .htaccess mais a vaudrait le coup d'essayer sinon Point de vidéos sur Firefox !.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Vidéo et Firefox

Message par allégorie le 21/3/2012, 18:34

Merci pour ces précisions
Le soucis que j'ai en fait est que les anciennes vidéos passent correctement sur firefox et les dernières que j'ai ajouté en suivant la même procédure ne se lisent pas.
J'ai encodé les vidéos en 3 formats MP4, OGV et WEBM.
Je précise que sur chrome tout passe bien.
Je vais vérifier les codes pour voir si tout est ok.

Cordialement.

allégorie
Simple Membre

Messages : 26
Inscription : 09/03/2011 Masculin Localisation : Eure et loir
Version iWeb : A remplir!
Publication : MobileMe

http://www.allegorieproductions.com

Revenir en haut Aller en bas

Re: Vidéo et Firefox

Message par Contenu sponsorisé Aujourd'hui à 16:29


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum