Problème sur le RSS

Aller en bas

Problème sur le RSS

Message par Benoit2 le 25/6/2012, 15:49

Bonjour,

Je suis une billet sous iWeb 3.0.3 que j'utilise sous mon Mac 10.5 en publication FTP...

Je rencontre un problème sur le RSS uniquement, peut-être pourriez-vous m'aider ?

Lors d'une lecture du blog via une syndication RSS du lien mon-Blog/rss.xml
L'imagette affichée en chapô (entête) de chaque billet n'est pas forcément l'image d'illustration du blog, une fois sur deux, c'est l'imagette de l'ancien billet qui s'affiche à tort

Je pense comprendre que seule la vignette (imagette) générée en chapô n'est pas correcte mais il y a toujours la bonne image qui pointe derrière;
On pourrait penser que la vignette adéquate n'a pas été sélectionnée pour publication et qu'iWeb prend la dernière vignette connue (? )

Exemple:

vignette (imagette) générée n'est pas correcte :
http://www.monsite.com/monsite/Le_Blog/Media/object001_15.jpg //sans rapport avec l'image souhaitée ci-dessous

la bonne image qui pointe derrière :
http://www.monsite.com/monsite/Le_Blog/Entrees/2012/6/21_TITRE_files/Image%201.jpg

La source du RSS est :
Code:
 <item>
      <title>Mon Titre…</title>
      <link>http://www.monsite.com/monsite/Le_Blog/Entrees/2012/6/21_TITRE.html</link>
      <guid isPermaLink="false">85</guid>
      <pubDate>Thu, 21 Jun 2012 11:12:34 +0200</pubDate>
      <description><a href="[b]http://www.monsite.com/monsite/Le_Blog/Entrees/2012/6/21_TITRE_files/Image%201.jpg[/b]"><img src="[b]http://www.monsite.com/monsite/Le_Blog/Media/object001_15.jpg[/b]" style="float:left; padding-right:10px; padding-bottom:10px; width:190px; height:142px;"/></a>Mon texteMon texteMon texteMon texteMon texteMon texteMon texteMon texte…<br/>texte divers<br/>Vous l’avez lu sur <a href="http://www.monsite.com/">www.monsite.com</a><br/><br/><br/><br/><br/></description>
      <enclosure url="http://www.monsite.com/monsite/Le_Blog/Entrees/2012/6/21_MONTITRE_files/Image%201.jpg" length="92309" type="image/jpeg"/>
    </item>
    <item>

Si cela vous parle et que vous auriez quelques idées pour me sortir de ce marécage ;-)

Amitiés
Benoit

Benoit2
Nouveau

Messages : 2
Inscription : 25/06/2012 Masculin Localisation : Strasbourg
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème sur le RSS

Message par koeklin le 26/6/2012, 10:00

Benoit2 a écrit:Lors d'une lecture du blog via une syndication RSS du lien mon-Blog/rss.xml
L'imagette affichée en chapô (entête) de chaque billet n'est pas forcément l'image d'illustration du blog, une fois sur deux, c'est l'imagette de l'ancien billet qui s'affiche à tort
C'est souvent un problème cache de navigateur. iWeb a la très mauvaise idée de renommer les images du récapitulatif de blog (et donc le RSS) au fur et à mesure qu'on ajoute une entrée
l'image 1 prends le nom et l'URL de l'image 2, la 3 ceux du 4 etc. , et ceci à chaque nouvelle page. Mais le navigateur lui ne rafraichit pas forcément toutes les images ; il va chercher certaines dans sa mémoire cache et donc affiche une ancienne version de l'image homonyme. Les développeurs d'iWeb auraient dû penser à ce problème.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Problème sur le RSS

Message par Benoit2 le 26/6/2012, 10:05

Bonjour,

merci pour cette info.
Quelle serait la solution pour éviter cela selon toi ?

A+

Benoit2
Nouveau

Messages : 2
Inscription : 25/06/2012 Masculin Localisation : Strasbourg
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème sur le RSS

Message par koeklin le 26/6/2012, 13:06

Ne pas utiliser iWeb pour faire son blog...

Wordpress est plus adapté pour cela

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Problème sur le RSS

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum