[résolu]non-affichage des ombres sur firefox...

Voir le sujet précédent Voir le sujet suivant Aller en bas

[résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 12:22

Bonjour,

J'ai utilisé iWeb 1 pour construire le site de ma femme en bidouillant aussi avec DreamWeaver (beaucoup plus complexe), sans instruction particulière, mais par tâtonnement on parvient à trouver ce que l'on cherche !
Mais voilà que j'investis dans l'achat d'un nouveau Mac la semaine dernière avec la suite iLife 08 incorporée et donc iWeb 2. J'étais au départ très heureux de pouvoir compter sur les évolutions du logiciel... mais je me suis rendu compte que l'affichage des ombres ne pouvait plus être visible que sur Safari dans cette nouvelle version !
Est-ce que quelqu'un sait ce qui a changé pour que Firefox par exemple puisse lire le site normalement ?

merci

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par koeklin le 21/5/2008, 12:53

Avant chaque fois que tu faisais une ombre dans un texte, ce dernier et son ombre etaient transformés en images
Maintenant les textes restent des textes et les ombres simplement générées par un code de style (CSS) , c'est moins lourd. Le problème c'est que seules certains navigateurs dont Safari sont capable de interpréter correctement ce code CSS et pas d'autres qui restent un peu à la traine de ce côté là(Firefox)

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par zepatente le 21/5/2008, 13:40

si tu fais apparaitre l'icone jaune d'image dans la zone de texte , elle sera alors transformé en image

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 13:50

Merci pour la réponse koeklin...

En d'autres thermes si je suis bien, il faut attendre pour voir Firefox se mettre à jour...
C'est un peu malheureux comme histoire.
Car, d'une part, il était bien pratique (même si c'était lourd au chargement, c'est vrai) d'ajouter une toute petite ombre, presque invisible, à une police pour être sûr de la voir apparaitre comme sur iWeb, et pas remplacée par une autre police lors du chargement de la page sur un autre ordinateur... (je sais bien qu'il existe d'autres façons de faire, mais intuitivement, c'était simple...)
Et d'autre part, le problème des ombres persiste aussi pour une simple ombre sur un objet !

Ma seule solution, pour le moment (à part de faire un stage approfondi sur DreamWeaver par exemple) c'est de garder iWeb 1 sur mon ancien ordinateur.

merci pour les infos...

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 13:55

zepatente a écrit:si tu fais apparaitre l'icone jaune d'image dans la zone de texte , elle sera alors transformé en image

@+

Pardon... je ne comprends pas bien ce que tu entends par icône jaune... ?

merci

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par zepatente le 21/5/2008, 15:16

Oui essaie par exemple de donner de l'inclinaison à ton texte et tu veras apparaitre une icone jaune dans le coin droit qui t'indique que le texte est devenu une image ( je montre un exemple dans le tutoriel video sur mon site , au milieu de la vidéo)

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 15:32

oui effectivement ça marche !
c'est génial
merci

reste les ombres sur les objets...
je les utilise sur mon site pour donner une idée de relief. Pour l'instant je n'ai pas de solution.
http://www.sophie-lloyd.com

merci quand même

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par zepatente le 21/5/2008, 15:37

Juste pour info , tu travaille sur iweb 2 ? car dans le code on voit 1.1.2

@+

ps: le site à l'air magnifique malheureusement je suis sur PC au travail pale

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 15:51

Oui j'ai créé ce site sur iWeb 1 avec quelques combinaisons sur DreamWeaver et Lightroom... mais je ne peux plus faire de mise à jour ou correction avec mon nouvel ordinateur Mac et la version iWeb 2 en raison de ce pb d'ombres... c'est bête (j'utilise donc mon bon vieux mac pour faire le "webmaster")!

merci

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par zepatente le 21/5/2008, 18:00

en fait , il faudrait que tu repère la fonction qui fait de l'ombre et la rajouter avec dreamweaver , enfin je m'y connais moins dans ce domaine , surement que jean ,koelin ou 27 avenue pourront te renseigner

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Matt le 21/5/2008, 18:08

merci pour tes réponses et bravo pour ton site très complet !

bye

Matt

Matt
Nouveau

Messages : 7
Inscription : 16/05/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par zepatente le 21/5/2008, 18:32

Merci Matt çà me touche beaucoup

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Madeline le 22/5/2008, 01:11

zepatente a écrit:en fait , il faudrait que tu repère la fonction qui fait de l'ombre et la rajouter avec dreamweaver , enfin je m'y connais moins dans ce domaine , surement que jean ,koelin ou 27 avenue pourront te renseigner

@+


Salut Matt
J'ai également eu ce problème et je l'ai solutionné (voir la discussion sur ce forum ) en faisant des captures d'écran dans iweb avec les ombres et en remplaçant les images ombrées (pour le relief) par les captures d'écran.
Un exemple du résultat ICI

-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html
avatar
Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par koeklin le 22/5/2008, 01:15

je te conseille la méthode de Zepatente si tu devais recommencer, Madeline.
En provoquant une inclinaison de la zone de texte celui se transforme en image et semble le rester si on revient à la position 0° ( mais je n'ai pas vérifié ce dernier point)

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Madeline le 22/5/2008, 01:35

koeklin a écrit:je te conseille la méthode de Zepatente si tu devais recommencer, Madeline.
En provoquant une inclinaison de la zone de texte celui se transforme en image et semble le rester si on revient à la position 0° ( mais je n'ai pas vérifié ce dernier point)

Salut Koeklin,
Mais c'est pas pour du texte que j'utilise la méthode capture d'écran, c'est pour donner du relief aux images en ajoutant une ombre portée comme si c'était des tableaux accrochés à une cimaise... il n'y a pas de texte !

-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html
avatar
Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par koeklin le 22/5/2008, 01:36

Ah zut! trés happy

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Madeline le 22/5/2008, 03:42

koeklin a écrit:Ah zut! trés happy

Quoi «Ah ZUT» ?
La solution capture d'écran en plus permet de protéger mes images... et d'alléger mon site... pour un téléchargement plus rapide... avec .Mac tourner la tete

C'est sûr que je perds un tout petit peu de netteté de l'image... mais imperceptible, à peine un chouïa.
Et au lieu de 3 images + la cimaise (exemple ICI j'en ai une!
Trois pour un comme pour les soldes good salut

-------------------
Mon site: http://madelinederiaz.com
Le projet «D'un printemps à l'autre»: http://www.postcard.madelinederiaz.com/site/Accueil.html
Graphisme et illustration: http://portfolio.madelinederiaz.com
L'art et la culture: http://forum.ravir.ca/fr/Accueil.html
avatar
Madeline
iWeb - Modo

Messages : 1088
Inscription : 07/02/2008 Féminin Localisation : dans mes rêves
Version iWeb : 3
Publication : locale

http://madelinederiaz.com

Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Invité le 22/5/2008, 06:05

Dans iWeb la zone Texte est comme une zone "Figure" simplifiée (Carré, rectangle)
Si vous n'y entrez que du texte et des paramètres de style (normal, gras, centré, souligné etc) cela reste du texte.
D'ailleurs dans l'inspecteur de Texte vous n'avez pas d'option "Ombre", vous ne trouvez cette possibilité que dans l'inspecteur de Graphisme.

Dans le cas ou après avoir sélectionné votre zone Texte, et que dans l'inspecteur de Graphisme vous cochez "Ombre" ( ou que vous sélectionnez un remplissage ou une bordure) votre zone de texte devient une Figure et sera enregistrée comme une image (shapeimage_x.png) dans dossier_files correspondant a votre page html.

A savoir aussi, dans le cas ou vous sélectionnez "Remplissage de l'arrière plan" dans l'inspecteur de Texte votre zone Texte devient une Figure et sera enregistrée comme une image (shapeimage_x.png) dans dossier_files correspondant a votre page html.

A savoir aussi, si vous entrez du texte dans une Figure Carrée/Rectangle et que vous supprimez le remplissage et la bordure et ombre celle ci devient une zone texte et ne sera pas enregistrée comme une image mais comme du texte.

Invité
Invité


Revenir en haut Aller en bas

Re: [résolu]non-affichage des ombres sur firefox...

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum