Problème de texte

Voir le sujet précédent Voir le sujet suivant Aller en bas

Problème de texte

Message par cedbarre le 26/8/2008, 14:35

Bonjour à tous,
je suis nouveau sur ce forum...
Je suis en train de créer un site pour ma société, jusque là, ça va à peu près ;-)
J'utilise une police, Century gothic, qui passe bien sur l'interface iweb, mais quand je publie la police s'affiche en gras... Pas moyen d'avoir ma police telle que je la vois sur iweb... Comment faire? J'ai trouvé une astuce sur le forum en appliquant des ombres mais là, ma mise en page est complètement différente!
Merci pour votre aide
Cédric

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par zepatente le 26/8/2008, 14:37

Bonjour et bienvenue ,

Y a t'il une icone jaune à droite du cadre de la police ?
et sur quel navigateur testes tu ton site ?

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 26/8/2008, 14:43

Bonjour
non, il n'y a pas d'icone jaune à droite, le T dans le menu police devient bleu, c'est tout...
Je teste sur safari, en fait j'enregistre et je fais "publier dans un dossier" puis "visiter le site"
Il n'est donc pas à proprement parlé sur mon serveur
ça peut jouer?
merci

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par zepatente le 26/8/2008, 15:14

RE,

l'équivalent de ta police est la "Futura" une police plus commune .

peux tu me dire si celà change quelque chose ?

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 26/8/2008, 15:43

re,
oui cette police apparaît correctement, mais me plaît moins que l'autre... Tant pis, je me résigne à la voir en gras...
J'ai d'ailleurs modifié ça sur une page et je n'arrive plus à l'afficher correctement. Dans l'aperçu, tout est mis en place n'importe comment, alors que dans iWeb tout est normal... Dès que je change un paramètre de police dans une page, tout se modifie (couleurs, mise en page etc...)
Je suis un peu perdu :-(

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 26/8/2008, 16:08

bonjour,
j'ai mis le site en ligne www.midi52.com
cliquez sur site... Vous verrez que toutes les polices apparaissent en gras, sauf la page "services" où en bas, la police apparaît comme je souhaiterais... Le truc c'est que c'est arrivé en bidouillant avec les ombres mais impossible ou de l'appliquer partout, ou de revenir à l'initial! Quelqu'un peut m'aider?
Merci beaucoup

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par koeklin le 26/8/2008, 19:37

l'adresse de ton site c'est http://www.midi52.com/Site/Midi_52.html
il manque une page index.html pour être redirigé de http://www.midi52.com/ vers http://www.midi52.com/Site/Midi_52.html

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 26/8/2008, 21:22

merci koeklin,
je l'avais oubliée "volontairement". Cette version en ligne est juste un essai pour vous faire part de mon problème de police
à+
Cédric

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par MireilleG le 27/8/2008, 01:56

Je pense que c'est un problème des substitutions des polices. voir une explication et peut-être la solution ici
Bonne chance
Mireille
avatar
MireilleG
Membre Accro

Messages : 592
Inscription : 14/01/2008 Féminin Localisation : Etats Unis
Version iWeb : A remplir!
Publication : MobileMe

http://www.clubiweb.com

Revenir en haut Aller en bas

Re: Problème de texte

Message par koeklin le 27/8/2008, 09:07

tout ce que je sais c'est que le choix de cette police de caractère va entrainer bien des problèmes. CedBarre va la voir comme il souhaite la voir (la coté gras mis à part) et les visiteurs eux vont avoir une mise en page totalement différente avec une substitution de polices de caractères par une autre.... Moi même je ne sais même pas si ce que je vois est le résultat souhaité.
J'ose même pas imaginer le résultat sou IE avec un PC (je vais regarder..)

Bon ben pas glop tout ça....

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: Problème de texte

Message par zepatente le 27/8/2008, 10:20

Bonjour,

En fait quand , j'ai écris mon premier message j'étais sous IE old school . tourner la tete

Et bien la police est plutôt bien interprêter , je voyais aucun problème pale

Mais comme tu le dis Koeklin , il est préférable d'utiliser des polices de bases .
Le grand gourou en parlait ici même http://iweb-forum.forumpro.fr/liens-texte-f22/bon-choix-des-polices-de-caracteres-t169.htm


@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 27/8/2008, 11:59

Merci pour vos conseils, je vais peut-être changer de police du coup et essayer les astuces que vous me proposez...
J'avais fait un essai avec du Arial, et l'ensemble apparaît encore en gras... Même si ce n'est pas très important, c'est tout de même enervant ;-)
un grand merci encore
Cédric

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par zepatente le 27/8/2008, 13:17

Re,

La futura est l'équivalent de ta police de départ

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: Problème de texte

Message par MireilleG le 27/8/2008, 15:34

Justement il y a quelquechose qui cloche si toutes les polices apparaissent en gras. Est-ce que la même chose se passe quand vous choisissez de mettre le texte en italique?
Est-ce que vous avez essayé de balancer le fichier plist (fermer iweb avant de le faire) et de relancer iweb?
Si vous avez un deuxième compte d'utilisateur sur le mac est-ce que le problème est présent quand vous faites un site sur ce compte?
Il faut trouver d'où vient le problème ensuite on peut le résoudre.
Mireille
avatar
MireilleG
Membre Accro

Messages : 592
Inscription : 14/01/2008 Féminin Localisation : Etats Unis
Version iWeb : A remplir!
Publication : MobileMe

http://www.clubiweb.com

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 27/8/2008, 15:43

Bonjour Mireille,
oui le problème reste en italique...
Je suis allé voir le site sur IE et la police est reconnue mais toujours en gras...
Le fichier plist? Je dois le supprimer?
Je n'ai pas de 2è compte sur le mac non plus...
J'ai changé plusieurs fois de police, tout est en gras à chaque publication
Merci
Cédric

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par oUamE le 27/8/2008, 15:56

Salut,
Et si tu appliques une ombre au texte et à tes cadres, ça change quelque chose ?
J'ai eu le même problème et je l'ai résolu comme ça ainsi qu'en changeant de logiciel FTP. (transmit à la place de Cyberduck)

oUamE
Simple Membre

Messages : 49
Inscription : 27/01/2008 Masculin Age : 46
Localisation : lyon
Version iWeb : A remplir!
Publication : Ftp integré

http://www.trenerone.fr/trenerone/

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 27/8/2008, 16:09

alors en fait, j'ai appliqué les ombres et ça m'a changé toute ma mise en page à l'affichage!
J'ai donc tout enlevé et c'est redevenu normal... MAIS certains cadres de textes s'affichent sans gras (dans la page "services" du site, les cadres du bas) mais impossible de savoir pourquoi! Les ombres n'y sont plus et quand je refais la même manip sur les autres ça ne change rien... Impossible d'ailleurs pour ces cadres de revenir en gras, incompréhensible...
J'essaie avec Transmit, on verra bien
merci

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par oUamE le 27/8/2008, 16:26

les cadres du bas sont bien avec ombre. (on ne peut pas sélectionner des bouts de texte, c'est donc bien une image), les autres non. mets bien une ombre pour le texte, puis une ombre pour le cadre. mon site est tout en century gothic et j'ai mis des ombres partout...

oUamE
Simple Membre

Messages : 49
Inscription : 27/01/2008 Masculin Age : 46
Localisation : lyon
Version iWeb : A remplir!
Publication : Ftp integré

http://www.trenerone.fr/trenerone/

Revenir en haut Aller en bas

Re: Problème de texte

Message par MireilleG le 27/8/2008, 19:54

Donc créez un deuxième compte sur votre ordinateur vous pourrez le supprimer plus tard. une fois créé faites un site sur ce compte et publiez le dans un fichier pour voir si cela cause toujours le problème.
Mireille
avatar
MireilleG
Membre Accro

Messages : 592
Inscription : 14/01/2008 Féminin Localisation : Etats Unis
Version iWeb : A remplir!
Publication : MobileMe

http://www.clubiweb.com

Revenir en haut Aller en bas

Re: Problème de texte

Message par cedbarre le 28/8/2008, 01:36

Bonsoir Ouame
justement, j'ai essayé d'appliquer les ombres à chaque cadre, mais ça ne fonctionne pas, c'est très étrange! Alors qu'en supprimant les ombres sur les cadres qui s'affichent correctement elles ne s'enlèvent pas non plus...

cedbarre
Simple Membre

Messages : 11
Inscription : 26/08/2008 Localisation : France
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Problème de texte

Message par MireilleG le 28/8/2008, 07:38

Cette histoire d'ombre est un peu dangereuse parce que tous les navigateurs ne vont pas montrer les ombres alors ça va beaucoup changer les choses.
Mireille
avatar
MireilleG
Membre Accro

Messages : 592
Inscription : 14/01/2008 Féminin Localisation : Etats Unis
Version iWeb : A remplir!
Publication : MobileMe

http://www.clubiweb.com

Revenir en haut Aller en bas

Re: Problème de texte

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum