Liens et navigateurs... Incompréhensible !

Voir le sujet précédent Voir le sujet suivant Aller en bas

Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 10:42

Bonjour à tous,
Sur mon site, vers les pages http://lefelain.prod.free.fr/Fedel_now_accueil.html , il y a des liens sur le manche d'une guitare. Ce sont des textes (dont le bloc texte prend tout l'espace entre deux barrettes du manche) que j'ai passé en "image" grâce à la fonction "ombre" pour que les polices ne deviennent pas n'importe quoi sur PC ou autres navigateurs que Safari.
Les problèmes :
Si dans Safari, tous mes liens fonctionnent à merveille, une fois sur FireFox (depuis ma plate-forme Mac ou depuis un PC), certains de ces liens ne fonctionnent plus sans que je ne comprenne pourquoi.
Autre chose grave, c'est que ceux qui fonctionnent ne peuvent être actionnés que si on positionne la souris au millimètre non pas sur le texte lui même mais un peu n'importe où et pas partout de l'espace où se trouve le bloc texte. Ce qui fait que; si tu ne cherches pas l'endroit précis où le lien est actionné, tu peux penser qu'il n'y a pas de lien...

Si vous avez une idée pour m'aider.

Merci.

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par abcdspp le 9/12/2008, 10:57

pense à bien mettre les liens situés dans le manche de la guitare … au premier plan … et vois si ça a résolu ton souci
avatar
abcdspp
Membre Actif

Messages : 74
Inscription : 02/04/2008 Masculin Age : 45
Localisation : Marseille
Version iWeb : A remplir!
Publication : Ftp integré

http://www.photoabcdspp.com

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 11:43

Bonjour Dominique,
Ils sont au premier plan, enfin, comme iWeb le permet toujours un peu en aveugle.
Si j'ai 10 liens et que je veux les mettre tous au premier plan, j'ai cru comprendre qu'il n'y en aura qu'un seul au premier plan, les autres descendant d'un plan à chaque fois que je voudrai que son voisin le soit.
Quoiqu'il en soit, je ne pense pas que ce soit ça puisque s'ils n'étaient pas au premier plan, du moins auX premierS planS, il y aurait aussi problème dans Safari.

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Yanik le 9/12/2008, 12:24

Bonjour,

Vérifie déjà que les textes-titres ont bien été convertis en images (iWeb/préférences/afficher un indicateur de dessin du texte).
avatar
Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Yanik le 9/12/2008, 12:28

Rebonjour,

Sinon, essaye de ne faire qu'un seul bloc de l'ensemble de tes titres (en sautant des lignes), au lieu d'individualiser chaque titre. Hum, suis-je clair ?
avatar
Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 12:39

salut Yanick,
Oui oui, le monsieur encadré de jaune est partout sur ma page. Pas de problème, ce sont bien des images.

Quant à faire un seul bloc... pourquoi pas. Je vais aller voir ça.

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par zepatente le 9/12/2008, 15:20

Bonjour,

Quelle version de firefox utilisez vous?

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Yanik le 9/12/2008, 16:37

Re,

En faisant un seul bloc tu vas perdre les changements de couleur au passage de la souris. Mais c'est le seul moyen que j'ai personnellement trouvé pour avoir un affichage desl iens satisfaisant. Toi, tu ne sembles pas rencontrer ces problèmes sous Safari et Mac.
avatar
Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 16:56

Version de Firefox : 3.0.4

je confirme que sous SAFARI, tous les liens fonctionnent parfaitement tous sans avoir à chercher où positionner la souris au millimètre. Safari étant (puisqu'il s'agit bien du même ordinateur et de la même connexion) bien plus rapide à l'affichage que Firefox.
A savoir aussi que ce problème apparaît sous deux versions différentes d'Internet Explorer sous PC (je n'ai pas les numéros de versions qui sont sous deux PC différents loin de chez moi).

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par PJG le 9/12/2008, 20:18

Je suis sur Safari, il y a des liens qui ne fonctionnent pas.

PJG
Membre Hyper-actif

Messages : 245
Inscription : 09/05/2008 Masculin Localisation : Seine et Marne
Version iWeb : A remplir!
Publication : Ftp integré

http://picasaweb.google.com/pjgatt/

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 20:32

Ce site est en fait le regroupement de plusieurs "parties de site qui n'en forment qu'un" avec une même structure. Certaines parties n'ont actuellement qu'une page pour dire qu'ils sont en travaux (et ils vont l'être longtemps... ;-)) ). Donc les liens qui mènent à ces pages ne sont pas opérationnels. Là, c'est donc normal.

Par contre, je suis en train de tout republier en ayant pris l'option de Yanick (un seul bloc texte pour tous les liens sur la guitare) et ça semble bien fonctionner et encore plus pratque à faire. Faut simplement voir, une fois mis sur mon espace FREE, ce que ça va donner. En interne, ça fonctionnait autant sur Safari que sur Firefox (Mac).

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Yanik le 9/12/2008, 20:37

Et si tu essayais d'agrandir la zone texte de chaque titre ?
Sinon, il existe une autre solution qui consiste à mettre sur chaque titre un rectangle transparent et d'en faire le lien. Là aussi tu perds le changement de couleur. Le pointeur se change classiquement en main. Cela ne déroute pas les visiteurs et cela fonctionne bien sous Internet Explorer.
avatar
Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Yanik le 9/12/2008, 20:42

On est ensemble sur le site. Entre temps tu essayes une première solution. Si elle marche, conserve là. Je l'emploi la plupart du temps. Elle donne aussi satisfaction aux PCistes avec Internet Explorer.
Pour les liens sur les pages en construction, il vaut mieux : soit les supprimer provisoirement, soit mettre une indication "pages en construction".
avatar
Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par PJG le 9/12/2008, 20:47

Yanik a écrit:il existe une autre solution qui consiste à mettre sur chaque titre un rectangle transparent et d'en faire le lien.
Je n'en ai pas parlé parce que c'est un article que j'ai envoyé à Avosmac.
C'est une bonne solution. good
.

PJG
Membre Hyper-actif

Messages : 245
Inscription : 09/05/2008 Masculin Localisation : Seine et Marne
Version iWeb : A remplir!
Publication : Ftp integré

http://picasaweb.google.com/pjgatt/

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 20:51

Tout d'abord merci à toi car je viens de remettre en route le site et ça fonctionne. Enfin... ça fonctionne depuis mon mac avec safari et firefox. Je vais tester ça depuis un autre ordinateur PC, une autre connexion internet et d'autres navigateurs.
Mais là, c'est déjà un bon point que de t'avoir suivi.
Quant aux liens morts, je ne sais pas quand j'aurai à nouveau le temps de faire évoluer mon site. Alors j'ai préféré installer les images textes qui serviront de liens plus tard. En page d'accueil, on arrivera sans trop de problème à comprendre que ces pages là sont en travaux (panneaux de chantier, menu déroulant dans la première page de chaque partie de site en construction).

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par lefelain le 9/12/2008, 20:57

Pour les liens qui ne fonctionnaient pas :
J'avais joué sur les dimensions des blocs textes ; j'avais aussi fait attention soit de les faire se chevaucher, soit au contraire de ne jamais les faire se toucher... Même résultat désolant !
Quand à mettre des blocs invisibles sur les textes :
Je ne sais pas si ça a un rapport mais j'ai aussi essayé de faire un "double lien". Je m'explique : à l'origine, seuls les textes que j'avais sélectionnés étaient des liens. Pour que la souris ait plus d'espace pour cliquer sur le lien, j'avais aussi mis un lien sur le bloc (contenant le texte) en lui même. Ca n'a rien donné non plus.

lefelain
Membre Actif

Messages : 70
Inscription : 08/10/2008 Localisation : Drôme
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: Liens et navigateurs... Incompréhensible !

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum