(RESOLU) soucis affichage d'un iframe sur la page d'accueil

Voir le sujet précédent Voir le sujet suivant Aller en bas

(RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par lazur le 21/12/2008, 00:40

Bonsoir,
je voulais afficher sur ma page d'accueil les infos de ma page de blog (transformée en news). J'ai lu les topics relatifs à ce sujet et j'ai choisi de créer un frame, sur ma page d'accueil, pointant sur ma page de blog. Le hic c'est que le frame ne s'affiche pas, bien que l'on puisse le voir correctement quand je crée le fragment html sur ma page iweb.
Est-ce un soucis de dimension du frame ? est-ce dans mon code ? ou bien est-ce un soucis du cté de la pomme et de mobile me ? ou encore un coup de ce satané père noel qui se joue de moi ? ou pour finir un hic dans le .me ou .mac du code ? je sèche


voilà le code : iframe src="http://web.me.com/seguette/collèrama/Informations/Informations.html" width="395px" height="410px" frameborder="0"> (j'ai viré les <> sinon ça s'affiche dans ce message, correctement en plus :))

et ici le lien de la page d'accueil : http://web.mac.com/seguette/collèrama/Bienvenue.html

et là celui de la page de news : http://web.mac.com/seguette/collèrama/Informations/Informations.html


Voilou

Merci si l'un d'entre vous à la solution sinon joyeux noel à tous

Lazur


Dernière édition par lazur le 21/12/2008, 03:01, édité 1 fois
avatar
lazur
Simple Membre

Messages : 24
Inscription : 25/08/2008 Masculin Localisation : Toulouse
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/seguette

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par zepatente le 21/12/2008, 02:02

Bonjour,

je t ai envoyer le code par mail

@++

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par koeklin le 21/12/2008, 02:11

tu mets le code suivant et ça régle ton problème :

Code:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<html>
<head>-
  <META HTTP-EQUIV="Content-Type" CONTENT="text/html;charset=UTF-8">
</head>
<body><iframe src="http://web.me.com/seguette/collèrama/Informations/Informations.html" width="395px" height="410px" frameborder="0">
</body>
</html>

edit: grillé par Zepatente? trés happy

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par lazur le 21/12/2008, 03:00

alors là je suis bluffé par votre réactivité (si tardive) et je viens de me prendre un verre (d'eau héhé) pour le lever à vos connaissances en la matière.
Le code de Zepatente ne fonctionnait pas mais celui de Koeklin oui.
Merci encore à vous deux. je suis content de pouvoir afficher mes "news" directement sur la page d'accueil.

Bonne nuitée à vous

lazur

ps : pourquoi existe t il différents codes pour la même action ? c'est déconcertant pour le novice que je suis ....parce que je sèche souvent pour une manip qui semble identique et qui marchait correctement sur une autre page du site.... aller je reprends un verre pour la peine causée ...^^
avatar
lazur
Simple Membre

Messages : 24
Inscription : 25/08/2008 Masculin Localisation : Toulouse
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/seguette

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par zepatente le 21/12/2008, 07:06

c'est juste que marc a eu la meilleur idée que moi de mettre une entête et qui était la solution .

même base de code mais pas les mêmes effets

Well done marc good

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par koeklin le 21/12/2008, 08:04

En fait l'entête est là pour dire "tu causes la France mon p'tit gars!" (= charset=UTF-8 ) sinon iFrame s'ouvrait vers
http://web.me.com/seguette/collèrama/Informations/Informations.html
et non vers
http://web.me.com/seguette/collèrama/Informations/Informations.html

et ben ouais il peut y avoir des problèmes d'accents sur mobileme (uniquement dans les widgets HTML).
C'est bizarre parce que je pensais que les widgets HTML rajoutaient systématiquement une entête et des bouts de codes html basiques manquant comme les balises head body et html le charset=UTF-8

Marc

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par lazur le 21/12/2008, 12:50

*toc toc sur la porte doucement-toussote*
je relance le topic parce que ..heu heu comment dire, je viens de m'apercevoir que les liens fonctionnement à merveille mais les pages apparaissent dans la fenêtre du frame. Dois-je supprimer les liens et placer un lien unique en bas de la zone du frame ou existe-t-il une ligne de code qui autorise d'afficher la page dans la fenêtre principale ?

Après j'arrête c'est promis Wink

Merci si y a ou pas de soluce :)

Lazur
avatar
lazur
Simple Membre

Messages : 24
Inscription : 25/08/2008 Masculin Localisation : Toulouse
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/seguette

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par koeklin le 21/12/2008, 13:02

il existe un sujet récent similaire
faut peut être attendre que Zepatente ait un peu de temps :
http://iweb-forum.forumpro.fr/widgets-f19/frame-t257-20.htm#6193
mais je ne sais s'il proposera un truc qui s'adapte à ce type de lien, généré par iWeb et indépendant de notre volonté

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par lazur le 21/12/2008, 13:17

ça roule Koeklin, merci Wink
avatar
lazur
Simple Membre

Messages : 24
Inscription : 25/08/2008 Masculin Localisation : Toulouse
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/seguette

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par zepatente le 22/12/2008, 08:23

C'est Noël , il faut que je fasse ma livraison de cadeaux d'abord ... mince je suis démasqué carton

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par Brigitte le 22/12/2008, 10:08

Bonjour,

votre site est très bien fait,
comment avez vous fait vos diaporamas ???

les élèves aujourd'hui ont bien de la chance, nous on s'ennuyaient !!! je ne vous dis pas comment.
avatar
Brigitte
Membre Hyper-actif

Messages : 207
Inscription : 10/11/2007 Féminin Localisation : alsace
Version iWeb : A remplir!
Publication : Ftp integré

http://www.gite-alsace.eu

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par lazur le 22/12/2008, 11:25

Bonjour,
merci Brigitte c'est gentil pour l'appréciation du site. J'aurai adoré vous dire qu'il s'agit d'un code en java ce qui permet une fluidité des transitions et "noeud coloré sur le cadeau" (rhooo c'est noel après tout Wink) ça autorise aussi l'apparition de petites flèches lors du passage de la souris sur la zone du diaporama mais ........ trés happy non il s'agit tout simplement de BannerZest Wink il est drôlement bien fait ce logiciel. Je louche méchamment sur la version Pro d'ailleurs.

Aller j'en profite pour souhaiter de bonnes fêtes à toutes et tous.

Denis


Dernière édition par lazur le 22/12/2008, 11:37, édité 1 fois
avatar
lazur
Simple Membre

Messages : 24
Inscription : 25/08/2008 Masculin Localisation : Toulouse
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/seguette

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par Brigitte le 22/12/2008, 11:31

Merci pour le tuyau,
j'avais déjà regardé ce logiciel, mais je ne l'avais trouvé qu'en anglais,

voilà un cadeau de Noël trouvé pour mon ordinateur !!

je vais allez m'amuser là dessus, dans les prochains temps

joyeux Noël à tous
avatar
Brigitte
Membre Hyper-actif

Messages : 207
Inscription : 10/11/2007 Féminin Localisation : alsace
Version iWeb : A remplir!
Publication : Ftp integré

http://www.gite-alsace.eu

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par zepatente le 22/12/2008, 17:34

Bonjour Brigitte ,

il existe en français depuis toujours vu que c'est un produit made in Montpellier applaudire

@+

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par Brigitte le 22/12/2008, 22:06

alors là, je me cache, honteuse,

merci aux canadiens, de nous dire ce qui existe chez nous,
je m'en vais le magasiner, ce logiciel bien de chez nous !!! carton
avatar
Brigitte
Membre Hyper-actif

Messages : 207
Inscription : 10/11/2007 Féminin Localisation : alsace
Version iWeb : A remplir!
Publication : Ftp integré

http://www.gite-alsace.eu

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par zepatente le 22/12/2008, 23:39

T'inquiète pas je suis made in Bretagne Wink

zepatente
Membre Accro

Messages : 689
Inscription : 25/11/2007 Masculin Localisation : Québec
Version iWeb : A remplir!

Revenir en haut Aller en bas

Re: (RESOLU) soucis affichage d'un iframe sur la page d'accueil

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum