problème de "mise à jour" de mon site

Voir le sujet précédent Voir le sujet suivant Aller en bas

problème de "mise à jour" de mon site

Message par cornichonvert le 20/1/2009, 16:56

Bonjour,
J'ai mis mon site (fait avec iweb) en ligne à l'aide d'un FTP. Il y a environ une semaine j'ai fait de nouvelles modifications sur mon site et j'ai donc changé les 2 fichiers (index + dossier avec les infos de mon site - obtenu après avoir publier ça dans un dossier). Mon problème est que quand je vais voir mon site en ligne, il n'intègre pas les modifications et c'est toujours la version de mon site d'avant. Ce n'est pas la première fois que je fais des modifs et je ne comprends pas pourquoi cette fois ça ne fait pas la mise à jour... Est-ce normal?
Merci pour votre aide et vos réponses!
:)

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 20/1/2009, 18:16

Même après avoir vider les caches de ton navigateur?

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par abcdspp le 20/1/2009, 19:36

et même après une ré-actualisation de la page en cours d'affichage ?

abcdspp
Membre Actif

Messages : 74
Inscription : 02/04/2008 Masculin Age : 45
Localisation : Marseille
Version iWeb : A remplir!
Publication : Ftp integré

http://www.photoabcdspp.com

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 20/1/2009, 19:58

alors oui, même après une re-actualisation de la page en cours d'affichage et je ne sais pas ce que sont les "caches" de mon navigateur... Gené

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par Yanik le 20/1/2009, 21:24

Va dans le menu, Safari/vider le cache.

Yanik
iWeb - Modo

Messages : 916
Inscription : 03/11/2007 Masculin Localisation : France, Banlieue Parisienne Est 94
Version iWeb : A remplir!
Publication : MobileMe

http://web.me.com/kereol2/Site/Bienvenue.html

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 20/1/2009, 21:33

Le cache d' un navigateur sont un ensemble de fichiers que ton navigateur garde en mémoire sur ton mac pour ne pas les recharger et te permettre de retourner plus rapidement sur les pages que tu as visitées.
Si un site que tu visité a été modifié par la suite , le cache du navigateur peux te tromper et te montrer une version peu ou pas modifiée depuis ta dernière visite.

Pour le vider (par ex. dans safari )
barre de menu > safari > vider le cache du navigateur (alt + cmd + E )
confirmer. (quoique ça ne marche pas toujours, )
sinon retourne sur ton site avec un autre navigateur et regarde si tu n'a pas la nouvelle version de ton site.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 21/1/2009, 11:20

Ok, merci beaucoup pour ces infos. :) Malheureusement je viens de vider le cache et la nouvelle version n'apparait toujours pas... :s d'autres suggestions ? normalement la mise à jour est supposé se faire automatiquement ?

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 21/1/2009, 11:37

télécharge les fichiers qui sont sur ton ftp vers ton ordinateur pour vérifier que ce sont bien les pages nouvelles qui sont présentes dessus .
Sinon, donne nous le lien de ton site et indique nous ce que nous devrions voir dans la nouvelle version et pas dans l'ancienne.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 21/1/2009, 19:37

Je viens de télécharger les fichiers depuis mon ftp et se sont bien les pages de la nouvelle version. En revanche, je ne sais pas si ça a quelque chose à voir, mais je viens de me rendre compte qu'après le téléchargement, le tout (index+ dossier) pèse plus de 200Mo (j'ai 100Mo sur mon hébergement) alors que quand je publie le tout depuis iweb, ça ne pèse même pas 40Mo. (en fait, de re-telecharger mes fichiers les font peser plus lourd, c'est un peu bizarre, je ne sais pas si ça a à voir avec ...)
L'adresse de mon site est www.ceciledavidovici.com la page d'accueil ne change pas (entrer en francais ou anglais) ensuite, dans la nouvelle version on voit 4 projets-films (rag doll / droit au but/ souviens-moi/ the accident) alors qu'il n'y en a que 3 dans l'ancienne version (rag doll / souviens-moi/ the accident)
Merci encore pour l'aide !!

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par abcdspp le 21/1/2009, 22:35

mon conseil …
efface l'ensemble des éléments sur ton hébergeur
et re-publie l'ensemble de ton site …

je n'ai pas ces soucis avec FETCH qui remplace automatiquement les fichiers lorsqu'ils ont le mm nom …

abcdspp
Membre Actif

Messages : 74
Inscription : 02/04/2008 Masculin Age : 45
Localisation : Marseille
Version iWeb : A remplir!
Publication : Ftp integré

http://www.photoabcdspp.com

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 21/1/2009, 22:49

Ton site est superbe ...
mais je suis comme toi, je ne vois que l'ancienne version
Maintenant je me pose des questions compte tenu de la presence d'un point d'exclamation sur le nom de ton site: site_cecile_!
Serait 'il responsable de dysfonctionnement, que ça ne m'étonnerait pas . D'une façon générale on évite de mettre des lettres accentuées, des apostrophes ou des caractères de ponctuation. Je ne sais si tous sont interdits mais je commencerais par éliminer cette possible cause de problèmes.
regarde si je colle une de tes adresses en entier sur le forum, celui ci refuse de me faire un lien correct
http://www.ceciledavidovici.com/site_cecile_!/home.html
il s'arrete au point d'interrogation. pour lui un point d'exclamation de doit être present sur une adresse de site. Pour ton FTP peut être aussi et je dirais même surement!
Renomme ton dossier "site_cecile_!" en "site_cecile" (sans les guillemets bien sûr , eux aussi interdits)
Par contre si tu ne retrouves pas de trace de tes dossiers 200Mo quand même pres de 170 en trop! )essaie un bon clientFTP comme transmit ( qui a une version démo gratuite d'un mois, et fais le ménage sur ton FTP ) ou fetch (que je ne connais mais que te conseille abcdspp).
il est possible que ton actuel client-FTP te cache des dossiers sur ton FTP

édition de 21h08 :
En fait, après réflexion je pense que plus que ton FTP, c'est ton client-FTP qui n'accepte pas les points d'exclamation.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par MireilleG le 22/1/2009, 05:01

Il y a aussi Cyberduck qui est gratuit et qui marche très bien.
Mireille

MireilleG
Membre Accro

Messages : 592
Inscription : 14/01/2008 Féminin Localisation : Etats Unis
Version iWeb : A remplir!
Publication : MobileMe

http://www.clubiweb.com

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 22/1/2009, 13:02

Méfiance quand même. A moins que son développeur ait fait les MAJ nécessaires, c'est typiquement le genre de problème que j'ai rencontré avec ce client-FTP. Avec Cyberduck j'ai uploadé des dossiers et des pages avec des accents, je me suis retrouvé dans l'impossibilité de les mettre à jour, renommer, effacer, éditer. C'etait certes un bon bout de temps mais j'ai cessé d'utiliser ce logiciel après ce problème. Transmit a pu corriger ces erreurs.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 22/1/2009, 16:29

Merci Koeklin pour le gentil mot sur mon site Wink

J'ai enlevé le point d'exclamation et j'ai tout remis sur mon serveur (j'utilise FETCH). La mise à jour n'est toujours pas faîtes. Je vais attendre un jour ou deux pour voir si le temps y fait quelque chose et sinon j'essaierai avec Transmit.

J'en profite pour poser deux ou trois autres questions :D

-quand je passe la souris sur une photo ou un lien, il y a un petit rectangle jaune qui apparait avec le nom du lien. Est-ce possible de l'enlever en changeant quelque chose dans les préférences?

-j'ai fait mon site avec mon ordi qui a un grand écran. Quand je regarde le site sur un portable (donc écran plus petit), la page reste aussi grande même si la fenêtre est plus petite et donc on est obligé d'utiliser la roulette sur le côté. Y-a-t-il quelque chose que je puisse faire pour remédier à ça et que le site apparaisse dans la totalité du cadre d'un coup?

-Enfin, dernière question, est-ce possible avec iweb de faire justement apparaître cette roulette dans une zone précise de ma page? Par exemple, quand j'écris ce message,(dans un rectangle noir) si le message dépasse une certaine taille le rectangle ne bouge pas et la roulette permet de voir le haut ou le bas du message.

Merci pour votre aide, elle est très appréciée!

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 22/1/2009, 17:30

cornichonvert a écrit:J'ai enlevé le point d'exclamation et j'ai tout remis sur mon serveur (j'utilise FETCH). La mise à jour n'est toujours pas faîtes. Je vais attendre un jour ou deux pour voir si le temps y fait quelque chose et sinon j'essaierai avec Transmit.

je crois que tu peux recommencer sans attendre
comment s'appelle le dossier où tu publies ton dossier site et ta page index.html? généralement c'est "web" ou "www".
Si ça continue demande de l'aide auprès de ton hébergeur aussi. il peux peut être effacer tes anciens dossiers

cornichonvert a écrit:-quand je passe la souris sur une photo ou un lien, il y a un petit rectangle jaune qui apparait avec le nom du lien. Est-ce possible de l'enlever en changeant quelque chose dans les préférences?
Pas à ma connaissance
cornichonvert a écrit:-j'ai fait mon site avec mon ordi qui a un grand écran. Quand je regarde le site sur un portable (donc écran plus petit), la page reste aussi grande même si la fenêtre est plus petite et donc on est obligé d'utiliser la roulette sur le côté. Y-a-t-il quelque chose que je puisse faire pour remédier à ça et que le site apparaisse dans la totalité du cadre d'un coup?

Non, ça marche pas comme à la télé ( petite télé -> petite laurence Ferrari au JT, grande télé-> grande laurence Ferrari au JT trés happy )
c'est une question de résolution : ton site fait à peu près 1250 px de large et 900 de haut pour certaines pages si la résolution de l'écran est plus inférieur le site débordera.
Tu ne pourras faire plaisir à tout le monde
Quand je regarde les stats de mon site parmi les dix premières résolutions d' écran q'utilsent les visiteurs la plus basse est 1024x768. si tu veux faire plaisir à tout le monde va falloir faire des pages pas tres hautes de 560 pixel de hauteur max (jenleve près de 200px occupé par le dock la barre de tache du navigateur et la barre de menu, ça se trouve c'est pire sur PC), Pour des écrans pareils ta page st aussi trop large.

cornichonvert a écrit:-Enfin, dernière question, est-ce possible avec iweb de faire justement apparaître cette roulette dans une zone précise de ma page?
Si tu parles des ascenseurs. oui c'est possible en faisant une iframe, ce qui consiste a faire apparaître dans un cadre d'une page le contenu d'une autre page comme le cadre est souvent plus petit que la page qu'il est sensé montrer alors apparait un ascenseur.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 23/1/2009, 13:14

C'est bon ça marche! Youpi !
Merci beaucoup pour l'aide et les réponses Wink
A bientôt pour de nouveaux problèmes :o

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par koeklin le 23/1/2009, 14:25

cornichonvert a écrit:C'est bon ça marche! Youpi !
Merci beaucoup pour l'aide et les réponses Wink
A bientôt pour de nouveaux problèmes :o
Content pour toi.

Quelques question, stp :
Quel logiciel utilisais-tu pour mettre ton site sur ton FTP auparavant, quand tes soucis sont arrivés?
Et avec quel logiciel as tu pu finalement résoudre ton problème?

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.

koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par cornichonvert le 23/1/2009, 20:32

J'utilisais FETCH et j'ai réussi à résoudre le problème sans avoir besoin de changer de logiciel. Je crois que je devais faire quelque chose de mal à la base. Donc j'ai tout effacé puis j'ai refait ça depuis le début ! Ta question sur le nom du dossier dans lequel je mettais mes infos m'a guidée ! Je crois que j'ai du me tromper et mettre les infos au mauvaise endroit!
Merci encore trés happy

cornichonvert
Simple Membre

Messages : 12
Inscription : 20/01/2009 Localisation : paris
Version iWeb : A remplir!
Publication : Ftp integré

Revenir en haut Aller en bas

Re: problème de "mise à jour" de mon site

Message par Contenu sponsorisé Aujourd'hui à 22:46


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum