probleme lors de la publication

Voir le sujet précédent Voir le sujet suivant Aller en bas

probleme lors de la publication

Message par alias666 le 16/4/2012, 15:41

Bonjour,

J'ai réalisé mon site et publié via le ftp de iweb aucun souci sur les pages standard.
Par contre tous les fragments html ne s'affichent pas (notemment un formulaire jotform). Il s'affiche dans iweb, mais dès que je publie il y a la place vide.
Même problème pour les pages album et galeries photo. (Les images ne s'affichent pas).
Je précise que mon hébergeur est 1&1, et que je suis partie d'un modèle thème "Blanc" bidouillé.

J'ai déjà réalisé par le passé un site perso avec iweb hébergé par orange et la galeri ou le compteur (fragment html) fonctionnent bien.

Merci pour votre aide si vous avez des pistes de solutions... car je m'arrache les cheveux ! :-)

alias666
Nouveau

Messages : 6
Inscription : 03/04/2012 Féminin Localisation : france
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par koeklin le 16/4/2012, 16:28

ça ressemble beaucoup à une absence de certains fichiers javascript situés ordinairement dans le dossier nom_de_votre_site/Scripts

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par alias666 le 16/4/2012, 16:41

faut-il les ajouter manuellement alors?
Et ou est-ce que je peux les trouver ces fichiers?
Ils serraient absents lors de la publication uniquement...

Je ne suis pas très douée avec les codes et le language trop technique...
Ca fait le meme effet si je publie en local.

merci de votre aide...

alias666
Nouveau

Messages : 6
Inscription : 03/04/2012 Féminin Localisation : france
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par koeklin le 16/4/2012, 17:10

C'est possible de voir votre site?

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par alias666 le 16/4/2012, 18:53

Je ne souhaitais pas mettre l'adresse sur un forum, mon site n'est pas tout à fait terminé, je vous envoi l'adresse en mp.
J'ai donc remis les problèmes que j'ai sur la page contact. (mon formulaire ne marchant pas, je l'avais supprimé pour mettre un bouton mail)
Dessous la page contact j'ai ajouté le fameux formulaire et à gauche un lien vers la galerie des albums qui ne marche pas. (je souhaitait un album par prestation (PME / assoc/Particulier) avec le contenu des albums visible en passant avec la souris)

merci pour votre aide.

alias666
Nouveau

Messages : 6
Inscription : 03/04/2012 Féminin Localisation : france
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par koeklin le 16/4/2012, 19:34

Je confirme ce que j'ai dit précédemment
  • soit il manque le dossier Scripts sur votre serveur
  • soit il est là mais son contenu n'est pas là ou pas à jour

Bref il manque un tas de fichiers javascript.
A priori vous publiez d'abord dans un dossier et vous transférer ensuite vos fichiers publiés sur un serveur ce dossier se trouve dans le dossier créé par iWeb (le même qui contient vos pages et les dossiers au nom de vos pages (nomdelapage_files).

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par alias666 le 16/4/2012, 20:57

merciiii , effectivement le fichier script sur mon serveur n'est pas à jour, il date de la toute première publication (02/2012). donc à priori si je le supprime et recommence la publication, ça devrait fonctionner?
Dois-je supprimer uniquement le dossier script ou effacer le site entier avant de publier de nouveau....
Ce qui veut dire qu'à chaque MAJ je devrais faire cette manip' ? puisque le dossier script ne se met pas à jour seul.
Comment savoir quel est le fichier correspondant par exemple au formulaire?
Dans le dossier script il y a un sous dossier Widget..puis
DetailView /FooterControls / HTMLRegion / HeaderControls/ Navbar/ PlayButton/ SharedResources / Slideshow
c'est par ici?

alias666
Nouveau

Messages : 6
Inscription : 03/04/2012 Féminin Localisation : france
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par koeklin le 17/4/2012, 00:36

Juste le dossier "Scripts".

Ecraser celui qui est sur le serveur en uploadant un nouveau dossier "Scripts". Si ça vous dit vous pouvez effacer le vieux dossier Scripts avant d'uploader le nouveau mais généralement c'est pas nécessaire.

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par alias666 le 17/4/2012, 22:05

Super merci ça fonctionne... effectivement je viens de trouver l'article correspondant à ce soucis
http://iweb.debutersurmac.com/siteiweb/Blog/Entrees/2009/3/10_Javascript.html
je remplace tous les fichiers js qui sont inexistants ou non mis à jour et ça fonctionne.
Quel bonheur ! :-)
sauf que à priori je devrais vérifier tout ça à chaque mise à jour si je veux publier en direct via iweb... mais au moins maintenant je comprends ce qui ne marche pas !
Merci pour votre aide.

alias666
Nouveau

Messages : 6
Inscription : 03/04/2012 Féminin Localisation : france
Version iWeb : 3
Publication : Ftp integré

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par koeklin le 17/4/2012, 22:35

Content que ça vous ait aidé, il y a des fois où je ne me souviens pas du contenu de mes articles

-------------------
Débutersurmac.com (tutoriels vidéos): 'iWeb (de la version '06 à la version '09) - mon site iWeb (en construction)
Pas d'aide par message privé - merci.
avatar
koeklin
Membre Pathologique

Messages : 1924
Inscription : 20/10/2007 Localisation : le vexin
Version iWeb : A remplir!
Publication : Ftp integré

http://www.debutersurmac.com/

Revenir en haut Aller en bas

Re: probleme lors de la publication

Message par Contenu sponsorisé


Contenu sponsorisé


Revenir en haut Aller en bas

Voir le sujet précédent Voir le sujet suivant Revenir en haut


 
Permission de ce forum:
Vous ne pouvez pas répondre aux sujets dans ce forum